Inventory Performance (Viewability Threshold) not available on Standard Line Item editing UI
Incident Report for Xandr
Postmortem

Incident Summary

From approximately 01:34 to 05:47 UTC on Friday, May 22nd, 2020 Standard Line Items did not have the option to set or edit viewability threshold

Scope of Impact

During the incident window users could not set or change viewability threshold on Standard Line Items via the UI

Timeline (UTC)

2020-05-22 01:34: Incident reported by client

2020-05-22 04:25: Issue flagged with engineering team

2020-05-22 05:47: Root cause identified and Incident fully resolved

Cause Analysis

The root cause of the incident was planned deprecation of a feature flag which was tied to the viewability settings on Standard Line Item UI.

Resolution Steps

Our engineers resolved the issue by rolling back the changes made to the feature flag.

Next Steps

  • Define process to assess the scope of features flags better before releasing changes
Posted Jun 11, 2020 - 21:10 UTC

Resolved

The following incident has been fully resolved, and we will post a post-mortem as soon as we have completed one:

  • Component(s): Buy-side Console pages
  • Impact(s):
    • Unable to save/edit objects
  • Severity: Minor Outage
  • Datacenter(s): Global

We apologize for the inconvenience this issue may have caused, and thank you for your continued support.

Posted May 22, 2020 - 06:03 UTC