We're expecting data to be caught up in the next hours. We will post updates as soon as possible.
Posted Jul 15, 2026 - 10:21 UTC
Update
We are continuing to investigate this issue.
Posted Jul 15, 2026 - 09:11 UTC
Update
We're currently investigating this issue. We will provide updates as we learn more
Posted Jul 15, 2026 - 09:10 UTC
Investigating
Investigating:
We are currently investigating the following issue:
Geolocation(s): Global
Component(s): Reporting
Impact(s):
We're experiencing a data delay for multiple client-facing reports such as Seller Fill and Delivery, Curator Analytics, and Historical Data reports. Engineering is aware of this issue and is actively engaged in resolving it. Updates are not reflected for some objects, especially buy-side.
Not Impacted: Ad Serving, Bidding, Bidder UI, API, UI
Status: We will provide an update as soon as more information is available. Thank you for your patience.