Several CORS errors are increasing on AST calls end point
Incident Report for Xandr
Postmortem

Incident Summary

From approximately 19:00 UTC on Tuesday, June 21, 2022 until 15:30 UTC on Wednesday, June 21, 2022, some Adserver publishers experienced redirect errors affecting client-side Chrome traffic on desktop. This caused ads not to be displayed for some desktop users.

Incident Impact

Nature of Impact: For publishers who use Adserver, ads were not displayed for a subset of desktop users. 

Timeframe: 19:00 UTC Tuesday, June 17, 2022 to 15:30 UTC June 18, 2022

Customers Impacted: Monetize users, Ad Server customers

Scope: Global

Magnitude: Some publishers

Timeline (UTC)

2022-06-21 19:00: A code change to impbus was deployed to one server and rolled out over time.

2020-06-22 08:00: The impact of the issue was observed by clients and escalated to Xandr teams.

2020-6-22 10:30: Xandr teams rolled back the change.

2020-6-22 15:30: The change rollback was completed and the issue resolved.

Cause Analysis

The code change to impbus interacted with a third-party browser security check, generating an error sent to the user, not the server. 

Resolution Steps

Xandr teams rolled back the code change.

Next Steps

Xandr teams will enhance change management processes to highlight this critical interaction.

Posted Jun 29, 2022 - 15:15 UTC

Resolved

The incident has been fully resolved. We apologize for the inconvenience this issue may have caused, and thank you for your continued support.

Posted Jun 22, 2022 - 16:05 UTC
Update

There was testing related to the upcoming Chrome Client Hints worldwide release which caused some CORS errors to occur. The issue has been identified and we're working on fixing it as soon as possible. We'll provide an update when fully resolved.

Posted Jun 22, 2022 - 12:06 UTC
Identified

We're going to roll back to AST 0.48.1 release. We will provide an update as soon as possible. Thank you for your patience.

Posted Jun 22, 2022 - 09:14 UTC
Investigating

We are currently investigating the following issue:

  • Component(s): Ad Serving
  • Impact(s):
    • CORS errors are intermittently occurring on AST calls, preventing ads from serving
  • Severity: Major Issue
  • Datacenter(s): Global

We will provide an update as soon as more information is available. Thank you for your patience.

Posted Jun 22, 2022 - 08:29 UTC