Some Xandr Users are unable to access Grapeshot Keywords app
Incident Report for Xandr
Postmortem

Incident Summary

From 5:15 UTC 04/08 to 11:26 UTC 05/08, Grapeshot requests reaching the AMS datacenter would not be authorized, as they were including a header that the parent system considered invalid. Ad serving was not impacted due to redirection to NYM datacenter.

Scope of Impact

During the incident window clients using Grapeshot data were not negatively affected by the workaround.

Timeline (UTC)

2021-08-04 5:15 UTC: Incident Started: Initial errors logged for AMS requests.

2021-08-04 5:15 UTC: Incident Escalated: Redirection of traffic to NYM datacenter.

2021-08-05 11:26 UTC: Incident Resolved: configuration for Authorised Requests was reverted to a previous working version.

Cause Analysis

The root cause was the system unexpectedly applying a secondary authorization layer, which was also missing alerting mechanisms for those requests throwing errors.

Resolution Steps

The system was reverted to a previous configuration which allowed requests to not error out.

Next Steps

More mechanisms have been put in place to alert of erroring requests; additionally, the system has been updated to handle requests without headers.

Posted Sep 22, 2021 - 09:43 UTC

Resolved

The incident has been fully resolved. We apologize for the inconvenience this issue may have caused, and thank you for your continued support.

Posted Aug 05, 2021 - 15:25 UTC
Monitoring

We have patched the issue and are monitoring our systems closely. We will provide an update as soon as the issue has been fully resolved.

Posted Aug 05, 2021 - 13:42 UTC
Identified

We have identified the cause of the issue, and our engineers are actively working towards a resolution. We will provide an update as soon as possible. Thank you for your patience.

Posted Aug 05, 2021 - 11:44 UTC
Investigating

We are currently investigating the following issue:

  • Component(s): API
  • Impact(s):
    • Latency, timeouts and errors in API
  • Severity: Minor Outage
  • Datacenter(s): AMS1

We will provide an update as soon as more information is available. Thank you for your patience.

Posted Aug 05, 2021 - 09:28 UTC