Self-Hosted Video Creative Upload Not Working as Expected
Incident Report for Xandr
Postmortem

Incident Summary

On December 9th, 16:35 UTC to December 10th, 01:20 UTC, members with the "self-hosted video" feature experienced an error while attempting to save self-hosted videos.

Scope of Impact

Members with the self-hosted video feature were unable to edit existing creatives during the incident period. There was no effect on ad serving.

Timeline (UTC)

2019-12-09 16:35: Incident Started: Creative API Release

2019-12-10 00:52: Incident Escalated to engineering

2019-12-10 01:20: Incident Resolved: Rollback of Creative API

Cause Analysis

The incident was caused by an application release which contained an unexpected Null Pointer Error for this specific type of creative.

Resolution Steps

The issue was resolved by rolling back the release to the Creative API.

Next Steps

  • Improvement of functional testing for the self-hosted video feature.
Posted Dec 17, 2019 - 22:06 UTC

Resolved

The incident has been fully resolved. We apologize for the inconvenience this issue may have caused, and thank you for your continued support.

Posted Dec 10, 2019 - 01:24 UTC
Investigating

We are currently investigating the following issue:

  • Component(s): Creative uploads
  • Impact(s):
    • Unable to upload self-hosted video creatives
  • Severity: Minor Outage
  • Datacenter(s): Global

We will provide an update as soon as more information is available. Thank you for your patience.

Posted Dec 10, 2019 - 01:08 UTC