Unable to upload new creatives to Monetize

Incident Report for Xandr

Resolved

Our Engineering team has resolved the issue and creatives can be uploaded correctly now. We apologize for the inconvenience this issue may have caused.
Posted Aug 31, 2026 - 14:37 UTC

Investigating

Products: Microsoft Monetize SSP, Bidder, SSP or Data Integration

Components: API, UI, Creatives

Impacted Clients: All

Description: We are currently investigating an issue preventing the upload and creation of new creatives in Monetize through both the UI and API. Existing creatives remain available. We will provide updates as they become available.

Status: Our engineering team is engaged and working on this issue with priority. We will continue to provide updates as we learn more.
Posted Aug 31, 2026 - 08:37 UTC