PSP Create New, listing page, and Request Sampler broken

Incident Report for Xandr

Resolved

Customers should now be able to create and edit PSP configurations successfully, and Request Sampler functionality has been restored. Engineering has implemented a fix and will continue to monitor the service to ensure stability.
Posted Jul 20, 2026 - 19:09 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 20, 2026 - 15:16 UTC

Update

We are continuing to investigate this issue.
Posted Jul 20, 2026 - 11:49 UTC

Investigating



We are currently investigating an issue affecting certain Prebid Server Premium (PSP) features within Monetize UI.
Customers may experience difficulties creating or editing PSP configurations and may see incomplete results when using
Request Sampler. Our engineering teams have identified the cause and are actively working on mitigation and recovery.
We will provide further updates as more information becomes available.





  • Component(s): Monetize UI



  • Impact(s):

    - Some customers may experience issues creating or managing PSP configurations and retrieving Request Sampler
    results in Monetize UI.




  • Not Impacted:
    - Ad Serving

    - Bidding

    - Reporting





Geolocation(s): Global (Global)




Status: We will provide an update as soon as more information is available. Thank you for your patience.


Posted Jul 20, 2026 - 11:49 UTC