Stale Reporting Data

Incident Report for Xandr

Resolved

This incident has been resolved
Posted Jun 12, 2026 - 18:03 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 12, 2026 - 12:29 UTC

Investigating

We are aware of an issue causing delays in several reports in Monetize and Curate. When running a report, users may find that the most recent data are over 6 hours old. Our engineering team is aware of the issue and working on a fix. Thank you for your patience!

In the meantime, please try different reports such as Network Analytics Report, as this will have all the data.
Posted Jun 12, 2026 - 09:13 UTC