Previews in political advertising report are not working
Incident Report for Xandr
Postmortem

Incident Summary

From approximately 16:43 UTC to 17:19 UTC on Thursday, April 2nd, 2020, the creative review API was down, causing issues with the Political Advertising Report UI.

Scope of Impact

The previews in the Political Advertising Report UI were not working properly for approximately 1 hour.

Timeline (UTC)

2020-04-02 16:47: Incident Started: Creative review release finished

2020-04-02 16:55: Post-release checking uncovered API issues

2020-04-02 17:06: Incident was escalated to Engineering team

2020-04-02 18:04: Incident Resolved: Engineering re-released the application

Cause Analysis

The root cause was a defect in the deployment tool configuration for a creative review application release.

Resolution Steps

This issue was resolved by fixing the defect in the deployment tool configuration and re-releasing the creative review application.

Next Steps

  • Add deployment to staging as part of the release process
  • Add monitoring alerts for the creative review API
Posted Apr 07, 2020 - 13:43 UTC

Resolved

The incident has been fully resolved. We apologize for the inconvenience this issue may have caused, and thank you for your continued support.

Posted Apr 02, 2020 - 18:30 UTC
Investigating

We are currently investigating the following issue:

  • Component(s): Console API
  • Impact(s):
    • Political Advertising Customer's Report
  • Severity: Major Outage
  • Datacenter(s): Global

We will provide an update as soon as more information is available. Thank you for your patience.

Posted Apr 02, 2020 - 18:11 UTC