Third-party video players update preventing Xandr from measuring viewability
Incident Report for Xandr
Postmortem

Incident Summary

From approximately 19:00 UTC on Wednesday, March 31st, 2021 to 17:49 UTC on Thursday, April 1st, 2021 a release to Google's IMA SDK reduced our ability to measure viewable video impressions. Clients buying on this KPI may have noticed a drop in delivery.

Scope of Impact

During the incident window clients performing buying that relies on predicted viewability (eg. Guaranteed Views) may have experienced a drop in delivery. Most clients that experienced underdelivery during this window would have seen delivery catch up following the incident, thereby mitigating overall impact. Historical viewability rates for publisher clients was not impacted.

Timeline (UTC)

2021-03-30 19:00:00: Incident Started: Google releases new version of the IMA SDK
2021-04-01 06:17:00: Incident Escalated: Automated alerts notify engineering
2021-04-01 13:52:00: New Viewability JS Release
2021-04-01 17:49:00: Incident Resolved: Viewability Measurement confirmed to be solved.

Cause Analysis

The root cause of the incident was determined to be a Google release to a new version of the IMA SDK, which was incompatible with the Xandr viewability measuring technology.

Resolution Steps

Our engineers resolved the issue by deploying a workaround that accounted for the release to the Google IMA SDK.

Next Steps

  • Continue monitoring 3rd party releases and their impact on our system
Posted Apr 12, 2021 - 16:58 UTC

Resolved

The incident has been fully resolved. We apologize for the inconvenience this issue may have caused, and thank you for your continued support.

Posted Apr 02, 2021 - 20:46 UTC
Monitoring

We have patched the issue and are monitoring our systems closely. We will provide an update as soon as the issue has been fully resolved.

Posted Apr 01, 2021 - 14:09 UTC
Identified

We have identified the cause of the issue, and our engineers are actively working towards a resolution. We will provide an update as soon as possible. Thank you for your patience.

Posted Apr 01, 2021 - 13:07 UTC
Investigating

We are currently investigating the following issue:

  • Component(s): Bidding, Reporting, Video, Viewability, Viewability Predictions, Mobile Web using IMA SDK
  • Impact(s):
    • Viewability rates will show as "non measurable" in reporting.
  • Severity: Partially Degraded
  • Datacenter(s): Global

We will provide an update as soon as more information is available. Thank you for your patience.

Posted Apr 01, 2021 - 09:55 UTC