Auction transactions 25% down in NYM2
Incident Report for Xandr
Postmortem

Incident Summary

Between approximately 18:35-19:25 UTC and 19:50-20:10 UTC on September 8, 2020 view prediction measurements stopped delivering to the NYM2 datacenter.

Scope of Impact

The Invest DSP stopped transacting approximately 25% of auctions in the NYM2 datacenter since view prediction measurements were required for some auction targeting objects. As a result, underdelivery may have occurred.

Timeline (UTC)

2020-09-08 18:35: Incident began
2020-09-08 18:40: Issue flagged and investigation began
2020-09-08 19:25: Affected components within datacenter restarted
2020-09-08 19:30: Incident cleared
2020-09-08 19:50: Incident began recurring
2020-09-08 20:02: Incident flagged again
2020-09-08 20:08: Affected components within datacenter restarted
2020-09-08 20:10: Incident resolved

Cause Analysis

The root cause of the incident was determined to be insufficient capacity for the affected component which was exacerbated by inadequate communication between that component and the NYM2 datacenter.

Resolution Steps

Our engineers resolved the issue by increasing capacity available for the affected components.

Next Steps

Increase communication capacity between the affected components and the NYM2 datacenter by updating the mechanism in charge of this. Review capacity planning framework to better consider and adjust to traffic demands.

Posted Sep 11, 2020 - 17:35 UTC

Resolved

The incident has been fully resolved. We apologize for the inconvenience this issue may have caused, and thank you for your continued support.

Posted Sep 08, 2020 - 21:05 UTC
Monitoring

We have identified and patched the following issue:

  • Component(s): Ad Serving
  • Impact(s):
    • Drop in delivery
  • Severity: Partially Degraded
  • Datacenter(s): NYM2

We are monitoring our systems closely, and will provide an update as soon as the issue has been fully resolved.

Posted Sep 08, 2020 - 20:28 UTC