“This line item requires peer approval before it can be activated” on Line Item Edit Screen which caused Line Item Status to be Uneditable on UI.
Incident Report for Xandr
Postmortem

Incident Summary

From approximately 00:06 UTC to 06:07 UTC on Thursday, January 14, 2021, users were unable to edit the status of Line Items on the Line Item edit screen due to a defect introduced by a product release.

Scope of Impact

During the incident window, customers were unable to make changes to a Line Item's status via the UI.

Timeline (UTC)

2021-01-14 00:06: Incident Started: Bug was introduced with the product release

2021-01-14 05:18: Incident ticket was raised

2021-01-14 05:18: Issue was escalated to Engineer

2021-01-14 06:07: Incident Resolved: product release which introduced defect was rolled back

2021-01-20 20:26: Issue was confirmed to be resolved and Incident ticket was closed

Cause Analysis

The product release introduced a defect that resulted in the status of the Line Item being uneditable.

Resolution Steps

Our engineers resolved the issue by performing a rollback of the product release that contained the defect.

Next Step(s)

• Set up more thorough tests before rolling out product releases

Posted Jan 22, 2021 - 03:47 UTC

Resolved

The following incident has been fully resolved, and we will post a post-mortem as soon as we have completed one:

  • Component(s): Line Item Edit Screen
  • Impact(s):
    • Line Item Status Uneditable on UI
  • Severity: Major Outage
  • Datacenter(s): SIN3

We apologize for the inconvenience this issue may have caused, and thank you for your continued support.

Posted Jan 14, 2021 - 06:42 UTC