Some Xandr Users Unable to Edit Deal Line Items
Incident Report for Xandr
Postmortem

Incident Summary
On Thursday, January 14th 2021 between 17:42 UTC and 19:42 UTC, an update to the API when out to production that prevented users and admins from being able to modify or create deals that contained any seat buyers.

Scope of Impact
Customers could not modify or create v2 deals

Timeline (UTC)
2021-01-14 17:42: Update was released, which began the incident
2021-01-14 18:50: Issue escalated from services to the engineering team
2021-01-14 19:38: Request to roll back update was made to the proper engineering team
2021-01-14 19:42: Update was rolled back and incident was resolvedCause Analysis
This incident occurred due to a release to our API.

Resolution Steps
The release that created this incident was rolled back so the functionality could be used as expected.

Next Steps
In the future engineering will include tests to prevent and detect potential issues like this from happening again.

Posted Jan 27, 2021 - 21:32 UTC

Resolved

The following incident has been fully resolved, and we will post a post-mortem as soon as we have completed one:

  • Component(s): Partner/Deal Console pages, Buy-side Console pages
  • Impact(s):
    • Unable to save/edit objects
  • Severity: Minor Outage
  • Datacenter(s): Global

We apologize for the inconvenience this issue may have caused, and thank you for your continued support.

Posted Jan 14, 2021 - 20:16 UTC