Missing Advertiser ID(s) in Some Reporting
Incident Report for Xandr
Postmortem

Incident Summary

From approximately 18:00 UTC to 21:00 UTC on Friday, March 6th and from approximately 21:00 UTC on Monday, March 9th to 17:00 UTC on Thursday, March 12th, approximately 0.9% of auctions were logged without an Advertiser ID. Billing remediation to correct affected auction data was completed at approximately 16:00 UTC on Sunday, March 29th. Reporting remediation to correct affected auction data was completed at approximately 22:00 UTC on Wednesday, April 8th.

Scope of Impact

As a result of this incident some clients may have seen an Advertiser ID of 0 in reporting for approximately 0.9% of auctions prior to remediation. Some clients may see a small number of conversions in Analytics reporting with an associated Advertiser ID of 0 through mid-to-late April.

Timeline (UTC)

2020-03-06 18:00 UTC: Incident Started: First reporting bake initiated

2020-03-09 21:00 UTC: Second reporting bake initiated

2020-03-10 14:30 UTC: Ticket escalated to Engineering

2020-03-13 11:45 UTC: Ticket escalated as Incident

2020-03-13 14:19 UTC: Incident Resolved

2020-03-29 16:00 UTC: Billing remediation completed

2020-04-08 22:00 UTC: Reporting remediation completed

Cause Analysis

The root cause of the incident was due to a change to improve the reliability of auction logging, which failed to set Advertiser ID in some cases and affected a small portion of auction data.

Resolution Steps

Data affected by this incident, including Billing Reports, the Network Analytics Report, and the Video Analytics Report, was remediated. Auxiliary reports and rapid reports were not remediated.

Next Steps

  • Improve automated testing of auction data logic.
  • Implement robust detection and monitoring to validate data integrity.
Posted Apr 14, 2020 - 15:21 UTC

Resolved

The incident has been fully resolved. We apologize for the inconvenience this issue may have caused, and thank you for your continued support.

Posted Mar 19, 2020 - 18:55 UTC
Identified

We have identified an issue with some reporting missing advertiser ID values starting at 18 UTC on March 6th:

  • Component(s): Reporting
  • Impact(s):
    • Some data incomplete or incorrect until reprocessed (please repull data as necessary)
  • Severity: Minor Outage
  • Datacenter(s): Global

Our engineers are actively working towards a resolution, and we will provide an update as soon as possible. Thank you for your patience.

Posted Mar 13, 2020 - 16:17 UTC